"Login failed for PanoramaDbUser" error during installation or upgrade

Summary and Scenario

Panorama upgrade to 6.2 fails with error "Login failed for PanoramaDbUser"

upgrade-fails

Cause
The upgrade stops at the step of creating a password for SQL user named PanoramaDbUser.
Possible causes:
1. Unsiffucient permissions for user that running the installation to create/edit the user details on SQL server.
2. The SQL user already exists

Solution
  1. Make sure that the AD user that runs the installation defined as SYSADMIN (it can be temporary definition) on the intended SQL Server.
  2. HKEY_LOCAL_MACHINE\SOFTWARE\Panorama\SetupVals branch is missing or corrupted because of previous installation tries. This is a crucial branch for the setup and upgrade process. You can download the branch from here. You can change the extension to REG, double click and it will add it to your registry. Make sure it overridden your existing (empty) branch.
  3. Go over every value and make sure it's correct with your environment. Pay special attention to:
    1. _NVDBServer and _DashDBServer - these should contain the name of your SQL server. If the server is on a named instance, write it accordingly (SERVER\INSTANCE)
    2. _NVServerPath - the installation path, on the file system, of your current NovaView installation.
    3. _NVSite - the name of the Panorama website, can be found in the IIS (usually "Panorama Site").
    4. All the database names are usually default as they appear in my registry, but double check that.
    After you've applied this registry and verified it's correctness, please run the upgrade again.

SetupVals branch download

Version
  • 6.0 and above
 
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