Cannot connect to Panorama database

SUMMARY

Cannot connect to Panorama DB, Cannot connect to panorama DB (w1200) or (w1203)

cannot_connect_to_panorama_db

If you are getting this error message, it usually implies a problem in the connectivity to SQL server.

CAUSE

You'll get this error message when the Tables in the SQL database are either corrupted, or they belong to another version of Panorama.

Typically you'll see this error when upgrading from Panorama NovaView 3.5 to Panorama NovaView 4.0, and the tables have not been recreated in the SQL database. 

Side effects when the SQL database tables are not created can include: problem with cache, error messages about UserOper, problems working with OLAP SETs, problem with Send View in the WebClient, Alerts, and Bookmarks in the Web Client.

SOLUTION
  1. run NovaView Administrator
  2. edit the Properties... in NovaView Administrator
  3. go to the Database tab
  4. make sure your SQL Server connection string is tested, and configured properly
  5. select Options
  6. then select Create Tables
For detailed instructions please see KB article: How To: Configure The Panorama Database

Troubleshooting

If you have done all the above, and you get the message again, then the best way to fix it is by creating a new SQL database. Then update the SQL server connection string, and Create tables for the new database.

VERSION
  • All versions.
 
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